Bug Report for NogsInserters

I saw that this was added when check on the mods today and figured I’d give it a go. Now I’m in Exper. due to the new pipes, etc and I unlocked the first inserters and was trying them out. They placed fine on the ground but when I tried to add power to them it completely froze the game, no error or crash. Music and sound kept playing. I went back tried on normal build for the game and still did it, but took a minute to register. *On EXP: instant, Normal Took a moment. Figured I’d pass it along

I do have other mods installed, (Wish there was a way to EXPORT mod list)
Light it up
Ficit-Networks
Mk++
Wall Pipe Supports
Floor Hole and Ceiling Logistics
Refined Power
Generator with More Pipes
Big Storage Tank and Megapump
Fluid Sink and More
Multi Splitter/Merger Balancer
Passive Mode
Conveyor Wall hole
100+ milestones and deps
Item Dispenser
Item Hopper
Resource Node Creator (added at the same time as Inserter)
Micro Manage
Fluid Extras
Powered Conveyor Stackable Pole
Programmable Elevators
X3 Roads
Icon Sign panel
Safe T-Walkways
Configurable Start
X3 Signs
Foundation Industries
Extended Power Poles
Packing Ficzip
Nuke Waste Cheat
Double Freight Car
Get Back here
Ramped Fences
10x AP
Satisfactory Helper
Wall Conveyors
Farming Mod
Boxed Uranium
Moarfactory +Deps
Rocket
Turbo Pumps
Magic Machine (Used for Testing)
Cheap Power Shards
Ficsalot
Daisy Chain Power Cables
Deco
Covered Conveyor Belt
More Fences
Exosuit
Adv Logistics
W Furniure
Pak Utility Mod
Sloped Walls
Extendable Walkways
Miner Mk4
Hard Drives Cheat
Utility Signs
Synthetic Paint
PUREX
Conveyors Mod
Holes

I have the same problem, with the same reproduction steps, and only installled NogsInserters

Same here. After that, even dismantling the inserter, any use of the cable to add power will freeze the game.

You can select the cable in the toolbar, but as soon as you hover over anything to attach it, the game freezes.

I will need Logs, specifically the pre-launch-debug.log from those crashes. Im not sure why not everyone has this problem though. Also maybe fixed already with the most recent Version.

Hello, I’ve got the same problem
In addition, you can no longer uninstall the mod

in modmanager writes: Dependency of InserterPlus

Can someone help me thank you

it’s a dependency of interesters plus, uninstall inserter plus to uninstall it. the reason why the SMM doesn’t let you remove it is to avoid issues with playing the game