Inventory and Storage

I made a warehouse in blender. How ever I haven’t been able to figure out how to open a widget with the inventory slots. Does this mean I have to create some kind of inventory system for it. Or is there one that’s built it that I can use…

Ice

If you want just the vanilla storage inventory UI and nothing more, set the interact widget of your building to Widget_Storage. It probably doesn’t exist as a reference in the starter project, but to create it, create an empty interact widget at the path FactoryGame/Buildable/-Shared/Widgets with that name.

Do you mean like this
FactoryGame/Buildable/-Shared/Widgets/Widget_Storage

I just tried it and no widget pop up. or is it like this

FactoryGame/Buildable/-Shared/Widget_Storage

Ice

The first one is correct, like this

Is your building a blueprint of class FGBuildableStorage? That widget only works for that kind of buildings (just tried that, if it is not, it shows the widget, but not the items)

Did you also check mIsUsable and set the mInteractWidgetClass to Widget_Storage as it says in the docs?

Yes, I did to both questions. The only thing I do know is that is there something I need to do to add items to that inventory so that they will be visible in the widget. I should still see slots when I open the Widget. and I know for some reason that doesn’t seem to work.

I did just that and it works
All I had to do:
image

image (maybe you didn’t do this one)

image

Nope, I have both of them setup just like the one you posted. Is there maybe any limits to the size by chance. I have Size X at 10 and Size Y at 20. image
image

For vanilla storages the X is 9, but I don’t think it should matter. Let me check

Set it to 11 and still works
Are you sure the path is correct?

Yes, I am, here look

Look again at my picture. The path should be Content/FactoryGame/Buildables/… not Content/FactoryGame/YourMod/Buildables/… because it is a reference to a vanilla widget, that UE will know what it is automatically when in-game

Ok, sorry I did miss that. Ok. I added a new widget to that folder

let me try this and I’ll be right back.

Nope, sorry that didn’t display the widget. I should be able to see the slots. idk

I wanted to post a screen shot. The forum says it’s too big oh and is your on discord and have some time to spare. add me iceman11a#8747

Update, From what I was viewing on this that the folder under my mods name folder. I don’t think those folders get compiled. Do they.

If it is not under your mod folder, it doesn’t, but that’s what you want to, because if it does compile it to your pak, it will override the original one with your empty one.

Did you delete the old Widget_Storage from your mod folder?

You can upload big images to imgur.com and link them here

yes. I did. I left the folder and removed the file

You probably did, but just make sure to compile + save the blueprints after you change anything in them, before running Alpakit

It happened to me many times to keep looking for a bug that I just forgot to save and alpakit

I save and compile every time I make changes

This is what I see before I open the widget https://imgur.com/a/qEDqOOM

This is what I see after I open the widget, https://imgur.com/a/RtAYR36

Update: I have another buildable, It’s a personal locker. I tried the same thing. Changing the widget to the Widget_Storage and it all so doesn’t work.

I have to sleep now, but can you upload your Buildable blueprints to google drive or something so I can take a look at them tomorrow? It would be easier then guessing what could be wrong through the forum

Yes, I can, I’ll send you a link for them in a few minutes

Update: There was a another Widget in the same folder as the Storage Widget. I have one machine that is a BuildableManufacturing. So I changed the widget to this Widget. and it worked. So there has to be something missing.

Here’s the link for the classes https://www.mediafire.com/file/m3vgc96n0pg9857/Warehouse.zip/file


Your asset is still looking for the incorrect path. Try setting the interact class to Widget_Storage again, and check if you have any leftover widgets at the path in this image