Refined power borked

when i try to use any of the turbines in the latest update, it crashes immediately. i’ve got the updated assets installed as well, same result.

just tried wind energy as well, i can place them, but soon as i go to connect lines it freezes everything computer the lot. it wasnt doing it until i installed the lastest update o your mod

I had the same problem on Steam with the Dyson Sphere using 2.1.8 Researched all the 4 parts and then tried to place it. Immediate CTD.

Also using Universal Power mod to get rid of those unsightly cables.

OK got it.

Is there any way to increase the time before repairs are sent? Trying to get enough screws to it in time is near impossible. I have more than enough screws available to send, but even with lvl 5 belts, you simply can’t deliver enough screws in the time allowed.

You are meant to use more than one port for some items. and no you can’t make it bigger, if you have a fully unlocked dyson sphere then it will want that much items to work fully, give it less items for less power if you don’t want to give it that many screws