Trying to decide whether to give up or not

So I only got into modding my Satisfactory game in the last few months. I used a bunch of mods but the two mods that make up the vast majority of my factory are Daisy Chain Power Cables and Floor Hole and Ceiling Logistics. Almost every machine on my factory was a Daisy Chain machine.

Then came Update 4 and now the vast majority of my factory is no longer there. At first I thought it might be because the mods were not updated for Update 4 but that is no longer the case. Both of those mods have been updated and yet my factory is still now an empty shell. Is there any way to fix this or do I have to start over from scratch? I really hope not because it took me a couple weeks of planning and building to create my factory and now it is gone.

This can be the problem for you:
Start the SMM (Satisfactory Mod Manager) And uninstall ALL the mod you’ve installed.
Then restart the SMM. If your mod isn’t red it COULD be fine…BUT!!! Go now to this page: and search for your mods. Because on SMM some of the mods are showing false that they are updated when it’s not.

If you have ONE mod that isn’t working (isn’t updated…) then the rest of the mods won’t work either…
So…take a look at the site and see first.

One more thing. When you have installed the mod/mods take a look at which version of SML you got (it should be 3.0.0)

I had the same issue after updates because I first launched the game without updating mods then updated them. So after updating mods you should loaded exactly the old save game where everything was in place.

Hope, this is your case and it will help

Sadly no. Every save game I have using my current factory has been destroyed by update 4. I HATE games that waste my time. This has made my mind up. Time to delete this waste of time off my machine. Once you have tried some of the mods, you no longer want to play the vanilla game without them but mods are pointless if they are going to destroy your game every time they update the game. I’m going to wait until release before I try this again. It just isn’t worth my time.

Same problem ware solved by deleting all mods and reinstalling them except those that are marked red.