SML preventing me from starting Satisfactory Early Access version

I haven’t played Satisfactory in a few weeks and when I tried to play recently, the SML UI suddenly popped up this error:

I checked the version and 118201 is apparently the latest EA version available, so why would it be “outdated”?

If I try to load the Experimental version, everything works fine. Only the Early Access version seems bugged.

For reference, I also tried disabling SML and starting Satisfactory without SML to try and see if the game would update, but no. Everything is still at release 118201.

Game loads fine without SML too.

Look under the Help dropdown and check your version. I think this was fixed in the latest version of 1.0.9. On the main screen for Early Access it should now should show v 2.0.0, and for the Experimental as shown in your screen shot.

Under the help menu, I only see the version displayed as 1.0.9. If there is a new version of SML, the software doesn’t see it.

I even tried uninstalling SML and reinstalling it from the installer on github, and still wound up with version 1.0.9.

OMG!!! After so many twist and turns I finally found how to fix the problem, but it’s SO convoluted!

Turns out, I had to update SML to 2.0.0 on EVERY config type individually.

  1. Select config type from the config drop-list under the satisfactory version drop-list (development, modded, vanilla)

  2. Once config type is selected, verify that SML update button for version 2.0.0 appears next to the satisfactory type drop-list

  3. Repeat steps 1 and 2 for each config type

I discovered that the “development” config type wasn’t updated to SML 2.0.0 when I was just blinding going around the UI in desperation. Modded was already updated since that’S the one I always use and vanilla didn’t seem to need it either (or it had already been updated.

Long story short, after updating “development” copnfig type, I was finally able to update mods and enter Satisfactory once again!

Is it possible to mark a post with a tag [Solved] in this forum?

I think 1.0.9 is the latest. When I select Early Access on the left, I get ‘SML: 2.0.0’ on the right.
When I select Experimental it shows SML: 2.1.0.
Sorry. Wish I could help.