Plugin 'SML' failed to load because module 'SML' could not be found

So I’m testing this new mod, and manually installed SML following the instructions from

Extracted SML to <game root>/FactoryGame/Mods now has ‘/FactoryGame/Mods/SML’
Placed my mod to /FactoryGame/Mods/.smod

After that I’m gettin’ an error that says:
Plugin ‘SML’ failed to load because module ‘SML’ could not be found.
Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project.

Still with the same message without my mod. Am I missing something here?

Yeah. I have a same issue . Did you solve the issue ?

I also have this issue. Anyone have a fix yet?

They are working hard to update all the documentation at the moment, personally you are far better off to use the Satisfactory Mod Manager as it also does all the settings and cleanup required when adding or removing mods. There has been massive changes to the mod manager and mod loader systems and things might not work as documented. If your really must manually install I suggest checking the satisfactory modding discord for more info and/or help.

I’m getting this error suddenly when it seems all I did was turn off mods in SMM to join a friends vanilla game, then when I turned the mods back on I’m getting this error. I tried restarting SMM, I’ve clicked on ‘check for updates’, I’ve restarted my computer, and uninstalled and reinstalled SMM from the ficsit page, and verified the Satisfactory install via Steam. Anything else I can try? Is this an update issue that I just need to wait out?

Hi there!
I believe the issue is with the fact that Satisfactory is now using a different launcher version (unity) and with this means the mod launcher had to get changed and modified as well. as of right now not all mods are functional with this new change and will probable be an issue fixed in the near future if not tomorrow. Hope this helps!

check out the Satisfactory Modding community on discord for updates like this:

Hallo zusammen ich habe das selbe Problem über den Mod Manager bei mir sieht die fehlermeldung so aus

Plugin SML failed to load because module SML could not be found. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project

hat jeman das Problem schon Gelöst?

SML worked on the latest version, but this time I could not install mods. :pensive::pensive:

Hi, Just got the game and was looking at the smart mod, I clicked install with SMM but when I try to load the game it comes up with this error. Does anyone know why?

i found way to solve the problem for me.
After installing SMM and the mods i want, i get the same error message.
CL151248 SML v3.0.0

Then i copied the SML binaries (*.dll, *.pdb) from

After that i modified the file
and add the SML Modul
“SML”: “UE4-SML-Win64-Shipping.dll”


@Thomas_Fiedler Hi. I could not find the files you mentioned above.

The files i metioned, will be copied to this location, after you install and activate SMM, with the SML v3.0.0.

Also you can find these files in the application path of the SMM.

For Steam you can find the application path in the settings/downloads/steam library paths.
For Epic you handled the application path during the installation process.

I understand why I could not find it, I do not use SMM, it must be because I do manual installation.

Thanks mate.

I followed the instructions up to this point, but what did you mean exactly by “modified”?


Presumably by “add” you mean copy from …\Satisfactory\FactoryGame\Mods\SML\Binaries\Win64?

tried that and then it failed to locate the “factorygame” module. I’m just going to uninstall SMM at this point until this is fixed because I can’t even launch the game through steam anymore.

the SMM isnt up to date :man_shrugging:

Error: Game version incompatible. Installed: 151248. SML requires >=151773
thats the problem

to find in AppData/Local/SatisfactoryModManager/logs

Correct the file seem to be a configuratiion via JSON. So you have to add the sml module in the config.

dont overwride the module file…
the module file should be modified… sorry bad wording.

I had the same error after change file BuildId version to latest 151248 it start running

sorry for my English I hope it helped



turn of the Mods button in the SMM to start the game without mods until SMM is patched